Upgrading servers

March 26, Wed
Affected Service: Web Application
  • Identified
    Please come back in 20 minutes

    01:26, Mar 26 UTC
  • Identified
    .

    01:27, Mar 26 UTC
  • Resolved
    Forgot to resolve this 20 minutes ago!

    02:32, Mar 26 UTC
Back to current status